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Overview
The Mobius Connect for Sage 50 CA Integration allows you to import your Manage accounting data directly into
your Sage 50 Canada application.

Feature Summary
Below is a quick list of features available within this integration:

1 Create Customers   

2 Create Vendors

3 Create Products

4 Multiple currency   

5 Standard Invoices   

6 Agreement Invoices   

7 Miscellaneous Invoices   

8 Down Payment Invoices   

9 Credit Memos   

1
0 Expenses   

 
a
. Transfer with Expense as Bill Option   

 
b
. Transfer without Expense as Bill Option  

1
1 Procurement   

 
a
. Item receipts   

b
. Inventory Adjustments   

 c. Inventory Transfers (Multiple Warehouses if available)

1
2 Sync Invoice Payments   

Feature is fully implemented Feature will be added in future release ●

Feature is partially implemented Accounting package does not support feature NA

Feature is not available
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Configuration

System Requirements
In order to use the Mobius Connect for Sage 50 CA Integration, you must have the following installed on your
network and/or your machine(s):

● Your Manage software must be setup up with login credentials that have access to the Accounting features
of Manage. Additionally, your Manage software must have its Accounting Package configured. See
ConnectWise Manage Configuration.

● Sage 50 Canada must be installed.
● Your Sage 50 Canada software must be set up with login credentials that have access to write to the Sage

50 Canada system that will be used.
● Your Sage 50 Canada software must be set up with a “3rd Party Integration” user. See Sage 50 Canada

Configuration.
● .NET 4.0 Framework or Higher must be installed on your system. If this is not installed, you will be

prompted to automatically install it when you attempt to install the integration application.
● Internet Access: While it is not required to have access to the internet every time you wish to run the

integration, updates will automatically download as they become available. Therefore, an internet
connection is recommended.

ConnectWise Manage Configuration
Before using the integration application, you must ensure that Manage is configured to allow the integration
program access to the accounting system.

Configuration of Manage Login
In order for the Member to be able to work with the accounting information, they must be assigned as a security
role that allows access to the GL Interface. With a default installation, the “Role ID” field must be set to “Admin”.

If, instead, you wish to create your own role rather than use the Manage defaults, you need to ensure that the
security role allows access for the Accounting Package and GL Accounts, as highlighted below.
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Additionally, you need to ensure that that the security role levels setting is set to “All” for “Inquire Level” on the
“API Reports” line within the System Module, as depicted below.

Configuration of Integrator Login
In addition to accessing the Manage Accounting System, the integration also requires credentials to access the REST

API. There are two options for providing credentials to access the REST API: APIKey and MemberImpersonation

Option 1: APIKey Authentication
To setup APIKey Authentication in Manage, navigate to the “API Keys” tab on the member setup for accessing the

Accounting System. Enter a description and click Save to generate a Public/Private key-pair. You may want to save

the Private Key somewhere as it will not be visible again once you close the API Keys screen.
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Option 2: MemberImpersonation Authentication
To setup MemberImpersonation Authentication in Manage, open the Integrator Login setup table by navigating to

System > Setup Tables and searching for “Integrator Login”. Click to create a new Integrator Login. Provide a

Username and Password, select “All records” for Access Level, and click to enable the “Member API”

Configuration of GL Accounts
Your company will need to have their GL Accounts properly configured in order for Manage to provide the
integration application with the correct information. Because this process is largely specific to your Company, the
exact details of this configuration are outside of the scope of this document. Please visit the ConnectWise
University before beginning to set up your GL Accounts, or speak with your Manage Consultant at
Consulting@ConnectWise.com for more information.
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Configuration of the Accounting Package
Once your accounts are set up, you will need to set up the Accounting Package. This describes to Manage how your
accounts will be exported to Sage 50 Canada. It has a number of options, some of which are specific to other
accounting software (such as QuickBooks). You can set up this screen at System > Setup Tables > Accounting
Package using the following steps:

1. Set the “Accounting Package Setup” dropdown to “Other.”
2. In the Sales Tax Options section, ensure that “Include Sales Tax” is checked.
3. If you will be transferring Expenses, ensure that “Transfer Expense as a Bill” is checked.
4. In the Product Options section, ensure that “Inventory SOH Option” is checked.
5. If you will be transferring Costing, ensure that “Include COGS Entries” is checked.
6. In the Account Segments section, choose the maximum number of segments an account in your company

will have. Ensure that each segment to be a part of your GL Account structure has a type of “Account.”
(Please note that Classes may be used in certain circumstances.)

7. In the COGS Segments section, choose the maximum number of segments a COGS account in your
company will have. Ensure that each segment to be a part of your GL Account structure has a type of
“Account.”
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Configuration of Invoice Number Prefix
It is necessary to use a non-numerical prefix when transferring AR Invoices from Manage to Sage 50 Canada. To

allow Manage to automatically add a prefix to all your invoice numbers, navigate to System > Setup Tables > Billing

Setup. You will have to perform the following step for each Division you will be creating invoices with that will

ultimately be transferred to Sage 50 Canada. Open a division and look for the “Include prefix/suffix on invoice”

checkbox. Be sure to select the “Prefix” radio button, and enter a non-numerical value to set the prefix that will

automatically be used by Manage every time an invoice is created.

Sage 50 Canada Configuration

Configuration of Sage Login
In order to allow the integration to successfully access Sage 50 Canada, you will need to configure User Permissions

within Sage for the integration user account.

1. Under Rights With Third-Party Products, select the “Read/write access” radio button.

2. Under Rights, verify that the user has “Full accounting rights” checked.
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Mapping Corresponding Data
There is data in Manage that will have corresponding data in Sage 50 Canada. For example, when you create an

invoice in Manage for the Company “Acme Inc.”, the integration program will need to create an Invoice in Sage 50

Canada for the Customer “Acme Inc.”. In order to know against which Sage 50 Canada Customer this invoice will be

created, Manage needs some way to associate the “Acme Inc.” in Manage with the “Acme Inc.” in Sage 50 Canada.

This process of associating data is known as mapping.

The following sections will describe what data needs to be mapped. When an improper mapping is found, the

integration program will fail before attempting to export any data, giving you the information needed to fix the

mapping.

Customers
Companies in Manage are mapped to Customers in Sage 50 Canada. The “Account” field on the Manage Finance >

Company Finance screen needs to match the “Customer” field on the Receivables > Customers screen in Sage 50

Canada. If a Customer in Manage has an invoice to be imported into Sage 50 Canada and the customer does not

exist in Sage 50 Canada, a new Customer will be created in Sage 50 Canada automatically.
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Vendors
Companies flagged as Vendors in Manage are mapped to Suppliers in Sage 50 Canada.  The “Vendor XREF” field on

the Manage Finance > Company Finance screen needs to match the “Supplier” field on the Payables > Suppliers

screen in Sage 50 Canada. If a Vendor in Manage has a PO to be imported into Sage 50 Canada and the Vendor

does not exist in Sage 50 Canada, a new Vendor will be created in Sage 50 Canada automatically.
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Members
Reimbursable expenses in Manage are created as Payable Invoices in Sage 50 Canada. Therefore, for each member

with an expense, a Supplier will need to be set up in Sage 50 Canada that corresponds to the Member. The “Vendor

Nbr” field on the Manage System > Members screen needs to match the “Supplier” field on the Payables >

Suppliers screen in Sage 50 Canada.
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GL Accounts
The “Account” field on the System > Setup Tables > GL Accounts table in Manage must be consistent with the

“Account” field on the Company >Chart of Accounts screen in Sage 50 Canada. Note that Accounts will not be

automatically created in Sage 50 Canada if they are not found. An error message will be raised when attempting to

push transactions.
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Accounts in Sage 50 Canada can only contain numerical values, so it is important that the account value in Manage

is setup to reflect this limitation. It is also important to set the number of digits allowed for an account number in

Sage 50 Canada. To do so, go to Setup > Settings > General (Accounts) > Numbering and select a value from the

“Number of digits in account number” dropdown.
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Tax Codes
In order to allow for the proper calculation of tax in both Manage and Sage 50 Canada, you need to map the Tax

Code you have set up in Manage to the tax code you have set up in Sage 50 Canada.

Multi-Level Tax Setup
Manage supports up to 5 levels of tax on a single tax setup. The following illustrates an example of a 5 tiered tax. It

is important to note that the “Tax Code” and “Tax Code Xref” fields (selected in red) are 2 characters in length. This

is a requirement of the fields that these values map to in Sage 50 Canada.
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The Tax Code and all of the Tax Code Xref values should be the same when setting up your Manage tax. It is also

important to note that the tax rate for each level is a decimal value. When creating your corresponding tax in Sage

50 Canada, the tax rate will be the percentage equivalent.
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To create the corresponding 5 level tax in Sage 50 Canada, you must first establish each level of the tax. To do so go

to Setup > Settings > Company > Sales Tax > Taxes. The “Tax” in Sage 50 Canada must be consistent with the

Manage “Agency Xref” for each level of the tax being created. The green selected values below match the green

selected values in the Manage illustration.

The integration will also validate that the Sage 50 Canada “Acct. to track tax charged on sales” account numbers

match the “Account” number for the Sales Tax Payable account type the Manage tax is setup to use.
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After a Sage 50 Canada “Tax” has been created for each Manage tax level’s “Agency Xref”, a Sage 50 Canada “Tax

Code” can be created. To do so, go to Setup > Settings > Company > Sales Taxes > Tax Codes. Click on the Code

column beneath the “No Tax” Description record to create a new Tax Code. The Sage 50 Canada “Code” must be

consistent with the Manage “Tax Code” and “Tax Code Xref” values. The red selected value below matches the red

selected values in the Manage illustration.

Double click on the new Sage 50 Canada “Code” to open the “Tax Code Details” interface. This is where you will be

able to establish the tax levels for your tax code.
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In the “Tax” column, click on the magnifying glass to select a tax. For each Tax set the percentage value equivalent

of Manage’s matching “Agency Xref” decimal value tax rate. (e.g. If Manage tax rate is .01, Sage 50 Canada percent

equivalent is 1).

Single Level Tax Setup
If you need to establish only a single level tax setup, follow the steps for the multi-level tax setup, but only create a

Level 1 tax in Manage. In Sage 50 Canada create only 1 “Tax” to assign to a “Tax Code.”
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PST on GST Tax Setup
If you need to establish a tax on tax configuration, you can do so by configuring a 2 level tax setup in Manage. You

will need to check the “Canada: Calculate PST on GST?” checkbox to enable the tax on tax calculation. When this

option is checked, the 2nd level tax will apply to the total after the 1st tax has been applied to an invoice.

To configure the same tax setup to map to in Sage 50 Canada, follow the steps outlined for the multi-level tax

setup. First create your Manage level 2 tax in Sage 50 Canada. When defining the Manage level 1 tax, in this case

“GST” as a “Tax” in Sage 50 Canada, click on the “No” in the column “Is this Tax taxable” for the “GST” record.

This will open the “Taxable Tax List” window where you can select which tax is going to tax your tax. Click on the

“Charge on GST” column for the tax record you would like to select. In this case PST.
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A checkbox will appear. Click Ok to save and close the “Taxable Tax List” window.

The “Is this Tax taxable?” column for your tax should say “Yes” when the “Taxable Tax List” closes. This setting will

calculate PST on GST the same as Manage. Continue establishing your tax setup as outlined in the Multi-Level Tax

Setup section to finish establishing your PST on GST Tax Setup.

Products
If you have Products in Manage that you keep track of, then the “Product ID” field on the Procurement > Product

Catalog screen in Manage must be consistent with the “Number” field on the Inventory & Services > Inventory &

Services Ledger screen in Sage 50 Canada. If a Product in Manage (on an Invoice or PO) is not found in Sage 50

Canada, it will be automatically created. Please note that the integration does not support serialization of products;

so, any serialized products in Manage will be created in Sage 50 Canada as non-serialized.
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Note: The integration will uppercase product numbers upon creating them.

Service vs. Inventory Product Type
It is important to note that Sage 50 Canada requires specifying a COGS class account for Inventory type products,

and an Expense class account for Service type products. This requires establishing special GL configurations in

Manage to differentiate cost of sales between these two product types.

Sage 50 Canada only has 2 product types, Inventory and Service. In Manage, however, there are 4 different “Type

Xref” values from which to choose when defining a Product Type: Inventory Part, Non-Inventory Part, Other

Charge, and Service. These XRef values dictate which item type will be created in Sage. The following table

illustrates these mappings.

Manage Sage 50 Canada GL Account
Inventory Part Inventory COGS
Non-Inventory Part Service Expense
Other Charge Service Expense
Service Service Expense

The “Type Xref” can be set in ConnectWise Manage System > Setup Tables > Products > Product Types. In the

following screenshot, we’re creating a Product type record called Fixed Cost Service. The Type Xref is of type

Service. All Fixed Cost Service products created in Manage will map to Sage 50 Canada as Service type products and

will therefore require an Expense class account to track cost of sales.
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In the below example, we’re creating a Fixed Cost Service. Note that the Category/Subcategory is set to Managed

Services / Managed Services.

In Manage, the cost of sales account will still be labeled “COGS”, but we specify different accounts for product

revenue using the Category / Subcategory. In the below example, only Managed Service category products will

have a “COGS” account of 54500.

In Sage, we can create our Expense class account 54500 by setting the Account Class to Expense on the Class

Options tab.
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Notice that if we were creating an Inventory Type product in Sage, our COGS account would need to be a Cost of

Goods Sold Account Class.

Now when we transfer an invoice with our REMOTE BACKUPS product, the expense account will properly link to

account 54500, which is an expense class account.

Properly configured Inventory Type products in Manage, will map to a separate Cost of Goods Sold account class.
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Item Receipts
Item receipts in Manage can be mapped to Sage 50 Canada in one of two ways by enabling or disabling the

“Vendor Invoice Number” module. To enable/disable the Vendor Invoice Number module, on the integration’s

main window, go to Options > View Modules.

This will open the Modules window where you should see the “Vendor Invoice Number Module”. In the bottom of

this window is a checkbox to enable/disable this module.
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With the Vendor Invoice Number Module Disabled
By default, this module is NOT enabled. The default behavior of the integration when handling Item Receipts is to

use the Manage “PO Number” as the Payable Invoice “Invoice Number” in Sage. The “Invoice Received” flag will

NOT be set, and the “Invoice Number” label will read “Reference No.”
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If you always use the Vendor Invoice Number in Manage, then you may want to enable the Vendor Invoice Number

Module. Enabling the module will require activating “Order Numbers” on the Sage Purchases Journal interface. To

do so in Sage, go to Setup > Settings > Company > Features and check “Orders for Suppliers” under “My Company

Uses.”
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With the Vendor Invoice Number Module Enabled
When the Vendor Invoice Number Module is enabled, the integration will use the Manage “Vendor Invoice #” field

as the Payable Invoice “Invoice Number” in Sage. The Sage Payable Invoice “Invoice Received” flag will be set, and

the Manage “PO Number” will be saved to the Payable Invoice “Order No.” field.

Please Note: When using the Vendor Invoice Number Module, extra validations are activated to ensure that all

Manage Item Receipts have a Vendor Invoice Number, and that “Order Numbers” have been turned on for your

Sage Purchases Journal interface.
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Inventory Adjustments & Transfers
If you use multiple locations for inventory items in Sage 50 Canada, you can map Manage Warehouses to Sage 50

Canada locations for transferring Manage Inventory Adjustments and Transfers. The position of a location in the

Locations setup screen located at Setup > Settings > Inventory & Services > Locations maps to a Manage Warehouse

Location Xref value as an integer. If the Sage 50 Canada Location is first in the list a Manage Warehouse with

Location Xref value of 1 would map to it. Consider the following setup:
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Clearing Transactions
If you do not have any transactions in Manage that you have already exported to an accounting package, you can

skip this section.

If you currently have transactions in Manage that you have either manually created in Sage 50 Canada (or

otherwise created in accounting software, and therefore have no need to account for them in Sage 50 Canada), you

will not want the integration application to export those transactions into Sage 50 Canada again.

To remove unnecessary records from Manage so that the integration does not attempt to export them, navigate to

the Finance > Accounting Interface. Go to the Unposted tab to remove unnecessary records. Select the

transactions, then click “Actions” > “Remove Records”.

You will receive a pop up to confirm this action. Please enter a Batch Number and click “Save”.
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Installation
To install the Mobius Connect for Sage 50 Canada Integration, follow the instructions below. Note that the steps

and screen shots are from a machine that already had the .NET Framework installed. Also, the browser in the

examples is Internet Explorer.

1. Go to the installation page: deployment.mobius-connect.com/Sage50SimplyIntegration.

2. Select your version of Sage 50 Canada. If you’re unsure, open Sage and go to Help > About Sage 50…

40
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3. Click Install.

The installation creates a Mobius Connect for Sage 50 Canada Integration desktop icon.

The application will open immediately after installation. You will be required to activate the integration with the

license key file. Click “Select License File” to install your license file and activate the integration.
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Using the Application

Logging In
The first time you run the application, you will be prompted for both your Sage 50 Canada and Manage credentials.

They will be retained on the Login screen for your convenience when you run the application the next time.

1. Enter the following Sage 50 Canada information in the Login screen:
● Company File: This is the file for your company. By default, your company file will be stored under

“C:\ProgramData\Sage50Canada\SageCanadaCompany”. Click the… button to bring up a menu to
help you choose the correct file. For example, the file chosen in the above example is
“C:\ProgramData\Sage50Canada\SageCanadaCompany\MobiusDev.SAI”. Note: Your company file
should have a file type extension of SAI.

● Username & Password: The login credentials of the user account that you have configured in Sage 50
Canada for Third Party Read/Write access. See Sage 50 Canada Configuration.

2. Enter the following Manage information in the Login screen:
● Site: The domain name of the Manage site. For example, “connectwise.mycompany.com”. Please

note: Do not include the “https://” part of the URL.
● Company ID: Your company database ID as assigned by Manage
● Auth Type: Select the method of Authentication setup in ConnectWise Manage Configuration

o MemberImpersonation: If using MemberImpersonation AuthType, enter your Member,
Integrator User, and Integrator Pass

o APIKey: If using APIKey AuthType, enter your Public Key and Private Key
3. Save Password – Check this box if you would like your Sage 50 Canada and Manage passwords saved for

the next time you run the application.
4. Click Login.
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The Main Screen
The following is a guide of the various parts of the Main Screen.

1. File Menu: The file menu gives you the ability to exit the application, or logout and return to the login

form.

2. Run New Batch: This tab allows you to select transactions and options needed to run a batch, which will

export a list of transactions from Manage and import them into Sage 50 Canada.

3. Rerun Previous Batch: This tab allows you to select a batch that was previously run. This is useful for

running a batch that successfully imported to Sage 50 Canada, but for reasons (such as a backup restore

on the Sage 50 Canada system), needs to be run again.

4. Update Invoice Payments: This will look for updated balances on Accounts Receivable invoices in Sage 50

Canada, and update the corresponding Manage invoice with the amount that has been paid.
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Running a New Batch

Setting up the Batch
The following explains how to use the integration application to run a new batch. This operation will export

transactions that you select from Manage and import them into Sage 50 Canada. When the operation finishes, a

new “Batch” is created in Manage that remembers the transactions that were part of the batch.

1. Select Location – If you are going to import records from a specific office location, choose the location

from the dropdown box. To import records from all available locations, leave the field blank. If you have a

location that is not present in the combo box, then that location does not have any transactions to export.

2. Select Through Date – If you wish to only select transactions that occurred up to a certain date, select that

date as the “through date”. Transactions that occurred after the “Through Date” will not show as

transactions that you can select for the batch.

3. Select Export Options – Select the various options that will control the export. These options are

described below:

a. Export Invoices – Check this box to have AR Invoices exported as part of the batch. Leaving this

box unchecked means that AR Invoices will not be exported as part of the batch.

b. Invoice - This dropdown allows you to select the level of detail that is shown on an invoice line.

For example, the invoice line for a Service Ticket in Manage might show in its description “Ticket

#1234 – Set up computer for new hire”. With “Default” selected, this invoice line will simply say

“Service.” The “Condensed” option will provide brief details and the “Detailed” option will

provide extensive details.

c. Export Expenses – Check this box to have reimbursable exported as part of the batch.

d. Export Inventory – Check this box to have inventory transactions (Item Receipts, Inventory

Adjustments, and Inventory Transfers) included as part of the batch.

You may sometimes find that a transaction you expected to be listed is not because of some missed step

somewhere along the way (such as an invoice never having been marked as “Closed”). After performing this step,

you can press “Refresh Data” in order for that transaction to show up in the list of transactions.
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Selecting Specific Invoices
By clicking on the “Invoices” tab, you can explicitly control which invoices you want to include in the batch.

Checking the checkbox in the “Include” column will cause the transaction to be included in the batch. Conversely,

unchecking the checkbox in the “Include” column will cause the transaction to NOT be included in the batch. You

may also click the “Select All” or “Deselect All” buttons to check or uncheck all transactions, respectively.
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Selecting Specific Expenses
By clicking on the “Expenses” tab, you can explicitly control which reimbursable expenses you want to include in

the batch.

Checking the checkbox in the “Include” column will cause the transaction to be included in the batch. Conversely,

unchecking the checkbox in the “Include” column will cause the transaction to NOT be included in the batch. You

may also click the “Select All” or “Deselect All” buttons to check or uncheck all transactions, respectively.

Note: Non-billable, non-reimbursable expenses do not transfer with the Expense as Bill option. However
Sage 50 US does not support transfer without the Expense as Bill option.

Non-reimbursable expenses need to be batched manually in ConnectWise to clear it out of the unposted
transaction list.
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Selecting Specific Inventory Transactions
By clicking on the “Inventory” tab, you can explicitly control which inventory transactions you want to include in

the batch.

Checking the checkbox in the “Include” column will cause the transaction to be included in the batch. Conversely,

unchecking the checkbox in the “Include” column will cause the transaction to NOT be included in the batch. You

may also click the “Select All” or “Deselect All” buttons to check or uncheck all transactions, respectively.

Select a Batch ID
Once you select the transactions that you want to export in the batch, you must pick a Batch Number.

Manage recommends that you use a separate batch for Invoice, Expense, and Inventory transactions. In order to

ensure that your batch numbers stay unique and easy to understand, a naming convention is also recommended. A

common naming convention might be the date, initials of the person running the batch, and the type of batch

being run. For example, if John Doe were to run three batches on January 1st of 2013, he might run the integration

three times with the following batch numbers:

● 20130101JD-I (Used for all invoice transactions)
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● 20130101JD-E (Used for all reimbursable expense transactions)

● 20130101JD-P (Used for all inventory transactions. “P” stands for “Procurement”)

Determine which Batch Number you wish to use, and type it into the “Batch Number” field.

Run the Batch
Click “Run Export”. This will start the export process.

Once started, a screen will appear that provides the status of the export process. When the export process

completes, you will have a description of the results in the lower part of the screen. At this point, you can save a log

of the results:

● Click “Save List of Errors” to create a file that contains the list of errors that occurred. You might have to fix

issues with various transactions and then rerun. Having this list of errors is helpful for listing those errors.

● Click “Save Full Log” to create a file that contains much more information on the errors and the cause of

those errors. This log is useful if you have a question on a specific error message and would like to send it

to a Mobius Works support technician, as it provides us a great deal of information that helps us discover

what happened.
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When the export finishes, you will be left in one of three states. You should read the text in the output screen to

determine the results of your batch. In general, you will experience one of three results:

1. The batch failed
In this case, an error occurred before any transactions started to be imported into Sage 50 Canada. These errors

might be as simple as not being able to connect to either Manage or Sage 50 Canada.

Additionally, this integration performs a number of validation checks before starting to push transactions to Sage

50 Canada. An example validation is to check to make sure that a Vendor has been mapped successfully and the

Vendor ID it was mapped to exists in the Sage 50 Canada system. If any such validations fail, the batch will fail

entirely.

You should fix whatever the error messages indicate, and try to run the batch again. Because no transactions were

exported, just as if you had never run the batch.

2. The batch completed successfully
In this case, the batch was run successfully. All selected transactions were exported to Sage 50 Canada and no

errors occurred. Additionally, Manage was updated with the information of all the transactions, creating a new

“Batch” with the Batch ID provided, that stores the list of transactions that were selected. These transactions will

no longer show in the integration screen since they are considered to have been transferred to Sage 50 Canada.

3. The batch completed, but some transactions contained errors
In this case, all the validation passed, and at least one transaction was successfully imported into Sage 50 Canada.

However, there were some transactions that failed. In this case, a batch is still created with the transactions that

did successfully transfer. Since a batch was created for the successful transactions, another batch will need to be

created once the unsuccessful transactions are corrected based on the suggestion(s) in the error message.

For example, assume that John Doe ran batch “20130101JD-I”, which pushed 25 successful invoices to Sage 50

Canada, but failed on three invoices. John should correct the issues described by the error messages, and then

create another batch for these last three. This new batch number could be called “20130101JD-I-1”

Validating a Batch
Although the integration program itself performs a number of validations (such as checking to make sure that an

account specified on a transaction is an account in Sage 50 Canada), it is a good idea to check some of the data to

ensure that things have worked reliably.

51



Invoices
To verify invoices in Sage 50 Canada, navigate to Receivables > Bills > Find Bill:

Expenses
To verify expenses in Sage 50 Canada, navigate to Payables > Invoices > Find Invoices:
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Item Receipts
To verify item receipts in Sage 50 Canada, navigate to Inventory & Services > Inventory & Services > View Inventory

& Services:
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GL Entries
Sage 50 Canada has 2 Product Types:

1.  Inventory

2. Service

These types are mapped to Manage Item Types as follows, and will apply the following transactions:

1. Manage   Inventory > Sage Inventory

o   Purchase (Item Receipt)

▪ Accounts Payable Credit

▪ Inventory Debit

o   Sale (AR Invoice)

▪ * Inventory Credit

▪ *COGS Debit

▪ Revenue Credit

▪ Accounts Receivable  Debit  

2. Manage Non-Inventory, Service, Other Charge (or NULL/Unknown) > Sage Service

o  Purchase (Item Receipt)

▪ Accounts Payable Credit

▪ COGS Debit

o   Sale (AR Invoice)

▪ Revenue Credit

▪ Accounts Receivable Debit 

*This transaction is handled by the accounting package directly, not the integration. 

Rerunning an Existing Batch
There might be a rare case where you have previously run a batch, and you wish to run that batch against your

Sage 50 Canada software again. For example, you might have run a batch successfully, only to have the Sage 50

Canada software require to be restored from a backup, thus losing all of the changes. In this case, you’d want to

rerun the batch.

One way to do this would be to use the Accounting Interface screen in Manage to delete the batch, but this means

that you would have to carefully select the transactions again, which could be error-prone.
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Another possibility is to click the “Rerun Previous Batch” tab in the integration program. In this tab, you would type

in the Batch ID, then click “Run” rerun the batch. The batch is then rerun against the Sage 50 Canada database.

WARNING: While this can be useful, this feature can be used to duplicate transactions in the Sage 50 Canada

system. This could occur if the transactions created in the Sage 50 Canada system, as a result of the first run of the

batch, still exist in the Sage 50 Canada system when the batch is rerun! Use caution when rerunning batches!
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Un-posting Transactions

Invoices
If you feel you’ve made an error on a particular invoice, you have the ability to un-batch it individually. Go to the

Invoice, and click on “More” > “Un-batch”.

Click OK to the verification message. The invoice will then be un-batched and will return to the unposted Invoices

list in the integration, ready to be exported. Please note that this did not delete the invoice from your accounting

package. You will need to do that manually.

Batches
If you feel you have made an error and need to restore some of the transactions that have been previously batched

from the “Unposted” tabs, you can delete the batch in Manage at Finance > Accounting Interface > Open Batches.

Click the checkmark next to the batch, then click “Actions” > “Delete Batches”.

Click OK to the verification message. The batch will then be deleted, and the transactions are again listed on the

“Unposted” tabs, ready to be exported. Please note that this did not delete the transactions from your accounting

package. You will need to do that manually.
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Synchronizing Invoice Payments
Your typical workflow will include creating invoices in Manage, and exporting those invoices to Sage 50 Canada.

However, when you receive payments from customers, you will use Sage 50 Canada to record that the payment

was received. Since it is useful to be able to look at an invoice in Manage and know if that invoice has been paid

without needing to access Sage 50 Canada, the integration program allows you to synchronize payment updates so

that Manage shows you what payments have been made to invoices. Use the following steps to accomplish this:

1. At the integration main form, click on the “Update Invoice Payments” tab.

2. Select the “Start Date”. You will have the following options for a Start Date:

● Last Successful Run: Will synchronize all invoices that were updated with new payment info in Sage 50

Canada since the last time the current user ran a synchronization on the current computer.

● Past Week: Will synchronize all invoices that were updated with new payment info in Sage 50 Canada in

the past 7 days.

● Past Two Weeks: Will synchronize all invoices that were updated with new payment info in Sage 50

Canada in the past 14 days.

● Past Month: Will synchronize all invoices that were updated with new payment info in Sage 50 Canada

since the current day in the past month (e.g., if today is the 10th of April, all invoices updated on March

10th and later will be synced).

● Custom Date: Will synchronize all invoices that were updated with new payment info in Sage 50 Canada

since a date of your choosing up until today.

3. Click “Run Sync”.

All invoices that were updated on or after the Start Date will have their payment info updated in Manage. This info

includes the total amount that has been paid, and the date that the invoice was paid in full. You can view these

results in Manage “Invoice Search” screen, by accessing Finance -> Invoice Search. Each invoice will have a “Paid

Amount” and “Date Paid” field. Note that the “Date Paid” field will only be filled with a date if the invoice was paid

in full.
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Additional Notes
Following are a few recommended settings to prevent Sage 50 Canada from providing feedback to the integration

that ultimately prevents certain actions from completing successfully.

1. Turn Off Automatic Advice in Sage 50 Canada

This prevents Sage 50 Canada from trying to provide “useful” feedback to the integration. If this

option is enabled and an action occurs which activates the “Automatic Advice”, the integration will

NOT be able to successfully transfer the batch it is processing. To disable Automatic Advice, go to

Setup > User Preferences > View > Uncheck Automatic Advice. Automatic Advice is user specific and

must be disabled for the user account that the integration will be using to connect to Sage 50

Canada.

60



2. Allow Transactions in The Future

In the event that you need to post invoices that are beyond your session date, you will need to enable

“Allow Transactions In The Future”. To do so go to Setup > Settings > Company > System > Check Allow

Transactions in the Future. This does not allow for posting

transactions prior to your fiscal period.

3. Allow Inventory Levels to Go Below Zero

If the integration creates a new Inventory Type item in Sage 50 Canada that does not already exist, the

quantity on hand will default to 0. If this item is immediately applied to a receivable invoice, the

integration will fail to create that invoice if this option is not enabled. To enable this option, go to

Setup > Settings > Inventory & Services > Options and check to enable Allow inventory levels to go

below zero.
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Customer Support
If you have any questions, please feel free to contact our consulting team at Help@ConnectWise.com or

www.ConnectWise.com/chat.

Contact Us
For more information about any of our products or services, please feel free to contact your Account Manager at

AccountManager@ConnectWise.com.

Don’t have an Account Manager yet? No problem! Please feel free to contact us at

http://www.connectwise.com/contact-us.

62

mailto:Help@ConnectWise.com
http://www.connectwise.com/chat
mailto:AccountManager@ConnectWise.com
http://www.connectwise.com/contact-us

