Error
QuickBooks Online payment [link] has applied credit with multiple invoices. Only one invoice can be present per QuickBooks Online payment when applying credit.
Cause
In this case, a single credit memo was applied to multiple invoices on the same transaction. The link in the error brings you directly to the payment causing this issue. Any payment entered in QuickBooks Online that contains a credit memo can only be applied to one invoice per payment transaction. If the user applies a payment containing a credit memo to more than one invoice then the sync will fail.
Resolution
You can apply a credit memo to multiple invoices by splitting it across multiple payment records. A payment record without a credit memo on it can be applied to multiple invoices. You will need to remove the credit memo applied and apply it to each invoice in a separate transaction.
Example
Credit memo 100 is for $100. Invoice 101 and Invoice 1022 are both for $50. You will need to apply credit memo 100 to invoice 101, save, and close. Then apply credit memo 100 to invoice 1022, save, and close.
Note: If Credit memo 100 is applied to invoice 1 and 2 in the same transaction, it will fail.