The name supplied already exists. Another Customer, Vendor, or Employee is already using this name. Please use a different name


Error

The name supplied already exists. Another Customer, Vendor, or Employee is already using this name. Please use a different name


Cause

Intuit does not allow duplicate Display names across Customers, Vendors, and Employees within QuickBooks Online. In other words, the Display name must be unique across all Vendors, Customers, and Employees. In this case, the same exact name has been used across multiple entities. To resolve this, please create a unique name for each entity in ConnectWise PSA. We often see this when a client is also a vendor and when QuickBooks Payroll is used while batching Employee expenses.

Examples

  • If there is a single entity, such as a Vendor, that is also a Customer or Employee, then please make an adjustment to one of the names in QuickBooks Online to differentiate between multiple entities. For example, if the Vendor is titled "ABC Solutions Incorporated", then the Customer or Employee name could be titled "ABC Solutions Inc." To access the employees in QuickBooks Online, navigate to Payroll>>Employees.
  • If a customer has been created by our integration, but then one of the name fields in ConnectWise PSA or QuickBooks Online has been changed.  Review our Customer Mapping guide, and ensure that all four fields (Company and Account ID in CW, and Company and Display name as in ) match.
  • You have changed the "Append Account" setting in Gozynta Mobius
  • You have trailing spaces in your customer ID.  "Interact " vs "Interact".  QuickBooks will remove the trailing space, while ConnectWise will keep it.  So when we create it, QuickBooks changes it from "Interact " to Interact".  When we look for "Interact " we don't find it because only "Interact" exists so we try again causing it to fail. ConnectWise will treat those as two separate items (and let you have both), and QuickBooks will delete the spaces from the end of the first one and treat them both as the same product.

Resolution

Vendor / Employee

To resolve a Vendor and Employee matching issue, we would recommend adding the Employee's Middle Initial to their name in ConnectWise PSA This should create a unique name for the employee's expense to batch over


Client/Vendor (With Append Account Name Disabled)

You will need to create 2 separate customers in ConnectWise PSA to resolve the issue.

For Clients: Add a "_C" to both the Account ID and Company field in ConnectWise PSA. 

For Vendors: Add a "_V" to both the Vendor ID and Company field in ConnectWise PSA.


Client/Vendor (With Append Account Name Enabled)

You can create 1 Customer in ConnectWise but change the Account and Vendor ID.

For Clients: Add a "_C" to the Account ID

For Vendors: Add a "_V" to the Vendor ID 

   

Additional Resources

  1. Customer and Vendor Mapping - Best Practice


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