The account period has closed and the account books cannot be updated through through the QBO Services API. Please use the QBO website to make these changes.

Error

The account period has closed and the account books cannot be updated through through the QBO Services API. Please use the QBO website to make these changes. 

Cause

You have received this error message because the integration is attempting to set an inventory 'As of date', that is before the 'Close the Books' date in QuickBooks. The integration is required to set the as of date when creating new inventory items. The purchase order, expense, or invoice date must be after the as of date on the invoice. Closing the Books will prevent any changes prior to the date set.

Resolution

You can see the last closing date in QuickBooks Online by navigating to the Gear Icon > Company Settings > Advanced
  • Invoices must be dated after this date.
  • Expenses must be dated after this date.
  • The Purchase order and receipt of all product must be after this date. 
You will need to updated the dates on all expenses, invoices, purchase orders and item receiving. 

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