The product revenue account "X" was given to be used in a transaction. However, no account with that name was found in your QuickBooks Online Company Chart of Accounts.

Error

The product revenue account "X" was given to be used in a transaction. However, no account with that name was found in your QuickBooks Online Company Chart of Accounts. 

Cause

The account mapped in the GL Setup Tables In ConnectWise PSA is incorrect. This error specifically calls out an issue with your Chart of Accounts in QuickBooks Online. The account name must match exactly with QuickBooks Online. I

Resolution

If this account does exist in QuickBooks Online, You will want to check if it's a sub-account. The easiest way to complete this is to open your Chart of Accounts in QuickBooks Online in Business View. Click the COGS Wheel at the top of the page. If it reads "Switch to Accountant view" then you are already in Business View. If it reads "Switch to Accountant view", click it. 

1. Select the cog wheel then select Chart of Accounts 

2. Select the Account you wish to map Click the Down arrow

3. Select "Edit" From the pop up list

4. If the "Is sub-account" Box is checked, then you must map ConnectWise with Subaccount:Account 

5. If the "Is sub-account" Box is not checked, then our best practice would be to copy the Name field and paste it directly into ConnectWise PSA. 


Please review the following articles to resolve the issue.

  1. GL Account Mapping
  2. GL Sub-accounts Mapping




Did you find it helpful? Yes No

Send feedback
Sorry we couldn't be helpful. Help us improve this article with your feedback.